會員登陸
帳號:

密碼:

記住我



忘記密碼?

現在註冊!
網站導航
最新下載
訪問統計 (自2012/5/3)


正在流覽:   1 名訪客





DEBUGGER跑正常,燒進去不正常...有什麼可能性?
資深會員
註冊日期:
2005/02/01 19:56
所屬群組:
註冊會員
文章: 244
等級: 14; EXP: 60
HP : 0 / 340
MP : 81 / 12646
離線
大家好想請問一下DEBUGGER和燒錄之後動作不正常的問題,
我使用DSP30F4011
程式有個功能會在一開機時用I/O讀取外面的指撥開關值,
在用這個值來設定CAN的FILTER/MASK
基本上有兩個I/O可設0-3共4種CAN ID,
再把對應的FILTER/MASK值設好
若外部送CAN 資料進來,號碼不對是不會回應的

外部測試配備使用LABVIEW的CAN模組送CAN資料給PIC,因為已經設FILTER/MASK了來擋了,所以PIC有CAN中斷進來就會執行功能回應

我用DEBUGGER (ICD3+MPLAB X IDE)去測試...發現指撥開關設0-3號,LABVIEW送對應的ID都會回應,送不對的ID就不回應,功能正常。

但燒錄程式進PIC之後,不管指撥開關怎麼撥,只有在LABVIEW設0號時才會回應。
指撥開關設0-3號,LABVIEW還是都要設0才會有回應,不知道有什麼可能性? DEBUGGER和燒錄程式之後跑起來有那些地方會不同嗎?

9月19日 16:35:19
轉換PDF檔 列印


Re: DEBUGGER跑正常,燒進去不正常...有什麼可能性?
版主
註冊日期:
2004/04/30 10:53
來自 CAE, Microchip
所屬群組:
站務管理者
註冊會員
MICROCHIP
文章: 14128
等級: 72; EXP: 47
HP : 1072 / 1786
MP : 4709 / 70391
離線
這三個指撥開關所用到的 I/O 有沒有做初始化的設定? 關閉 ADC 輸入,設成輸入功能。

我懷疑 Debug 的 F/W 做了這些動作,導致在 Stand-Alone Mode 下出了問題。

9月20日 12:50:26
轉換PDF檔 列印


Re: DEBUGGER跑正常,燒進去不正常...有什麼可能性?
資深會員
註冊日期:
2005/02/01 19:56
所屬群組:
註冊會員
文章: 244
等級: 14; EXP: 60
HP : 0 / 340
MP : 81 / 12646
離線
感謝回應....確實是ADCPFG沒有設對的問題.....問題已經解決
但是不知道為什麼在EMULATOR時卻運做的很好,造成模擬和燒錄時動作不同調

9月21日 06:49:14
轉換PDF檔 列印






無法在此發表文章
可以在此觀看文章
無法回覆文章
無法編輯自己的文章
無法刪除自己的文章
無法發起投票調查
無法在此投票
無法上傳附加檔案
無法不經審核直接發表文章

[進階搜尋]


搜尋
線上教學影片
網頁捷徑
2017 Summer Elite 報名
教育訓練
其它網站連結
電話: 02-25000405
產品技術問題產品技術支援專線:0800-717718 台北02-25088600 新竹03-5778366 Ext. 8600 高雄07-2137830 MicrochipDIRECT 專線: 07-2137830
Powered by XOOPS © 2001-2012 The XOOPS Project