• slider image 71
  • slider image 72
  • slider image 73
:::


Browsing this Thread:   1 Anonymous Users






MPLAB X IDE 總是在編譯時跳出視窗
#1
新會員
新會員


查看用戶資訊
請教為何每次在編譯時總會跳出一個視窗,該如何避免?

標題:Unexpected Exception
相關內容:A java.lang.NullPointerException exception has occurred. Click Show Details or see the messages.log file

點擊 "Show Details" 顯示如下:
java.lang.NullPointerException
at com.microchip.mplab.nbide.simdisplays.stimulus.models.RegInjectTableModel.refreshGPRsAndProgLabels(RegInjectTableModel.java:540)
at com.microchip.mplab.nbide.simdisplays.stimulus.ui.RegInjectPanel.handleProjectBuild(RegInjectPanel.java:299)
at com.microchip.mplab.nbide.simdisplays.stimulus.StimulusTopComponent.refreshPagesAfterProjectBuild(StimulusTopComponent.java:304)
at com.microchip.mplab.nbide.simdisplays.stimulus.StimulusTopComponent.Update(StimulusTopComponent.java:753)
at com.microchip.mplab.util.observers.Observable$1.run(Observable.java:31)
[catch] at java.lang.Thread.run(Thread.java:748)

作業環境:Windows 7, MPLAB X IDE v5.10, XC8 v1.45
編譯過程跳出來之後,編譯會完成,雖然沒發現到程式功能有不對,
但是每次編譯都會跳出來一次,每次都得關掉。

發表於: 2019/1/10 9:06
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong 頂部


Re: MPLAB X IDE 總是在編譯時跳出視窗
#2
版主
版主


查看用戶資訊
抱歉,這個問題我跟同事們詢問過大家都說沒遇過此問題。

我想只能建議一下,請確認認一下 Win 7 是否有更新?
或更新一下Java 的版本?

發表於: 2019/1/10 12:47
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong 頂部


Re: MPLAB X IDE 總是在編譯時跳出視窗
#3
新會員
新會員


查看用戶資訊
這個我之前也碰過,懷疑是更改了Harmony中 framework的程式,所以又重新安裝Harmony後就沒出現。

發表於: 2019/1/10 13:18
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong 頂部


Re: MPLAB X IDE 總是在編譯時跳出視窗
#4
新會員
新會員


查看用戶資訊
參照:

wychen 寫道:
這個我之前也碰過,懷疑是更改了Harmony中 framework的程式,所以又重新安裝Harmony後就沒出現。


Hello, 感謝提供經驗,但我沒有使用 MPLAB Harmony, 使用八位元 MCU。

發表於: 2019/1/10 14:33
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong 頂部


Re: MPLAB X IDE 總是在編譯時跳出視窗
#5
新會員
新會員


查看用戶資訊
參照:

Ryang 寫道:
抱歉,這個問題我跟同事們詢問過大家都說沒遇過此問題。

我想只能建議一下,請確認認一下 Win 7 是否有更新?
或更新一下Java 的版本?


Win7 有更新,Java 我更新了 jre-8u191-windows-x64.exe 之後,再開 MPLAB X IDE 編譯後仍舊會有此訊息。

一開始並沒有出現,不知道哪時候才突然開始有這現象的,因為沒有注意到畫面右下的紅框 Notification。

發表於: 2019/1/10 14:41

Edited by picer2012 on 2019年01月10日 15:11:20
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong 頂部







You can view topic.
不可以 發起新主題
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.
You cannot create PDF files.
You cannot get print page.

[進階搜尋]