Re: 如何讓 Harmony 專案使用舊的 PLIB 函數?

作者 AdamSyu 於 2018年07月02日 16:22:21
無法執行有幾個可能原因, 不過說在前面,
在Harmony底下, 使用PILB是很危險的, 兩套架構完全不相容,
使用時請確認衝突問題,

幾個可能問題,
1.沒有安裝PILB
XC32 1.34以前版本, PLIB在安裝XC32時, 就會一併安裝
1.34版本以後, 必須另外安裝XC 32 Peripheral Libraries.
2.
即是安裝了PLIB, PLIB也只有支援舊型號, 新型號只有Harmony支援,
3.沒有設定使用PLIB, 請參考圖片, 勾選Use Legacy Libc


其他的狀況, 還請PO一下錯誤訊息. 方便判讀. ^^

附加檔案:



jpg  01.jpg (67.38 KB)
7103_5b39e0290f48f.jpg 720X473 px

來自: http://www.microchip.com.tw/newbb/viewtopic.php?forum=8&topic_id=22339&post_id=78325